树莓派3刷LEDE(OpenWRT)打造路由器

准备工作

前往 LEDE 官网下载固件并验证:

https://downloads.lede-project.org/releases/17.01.4/targets/brcm2708/bcm2710/lede-17.01.4-brcm2708-bcm2710-rpi-3-ext4-sdcard.img.gz

注:bcm2710 是专为树莓派3准备的。
刷机软件:

SD卡烧录工具:Win32DiskImager (windows)

刷入LEDE系统

使用 Win32DiskImager 烧录 LEDE 系统镜像到 SD卡

安装SD卡到树莓派,开机。

网络配置

用一根网线连接笔记本和树莓派,设置电脑的IP为自动获取。树莓派的默认IP为192.168.1.1

SSH 登陆,并修改 root 密码

1
ssh 192.168.1.1 -l root

修改 /etc/config/network 配置文件,调整 lan IP为和路由器不冲突的其他IP,增加 wan 设置

1
2
3
4
5
6
7
8
9
10
11
12
13
config interface 'lan'
option type 'bridge'
option ifname 'eth0'
option proto 'static'
option ipaddr '192.168.1.11'
option netmask '255.255.255.0'
option ip6assign '60'
option gateway '192.168.1.1'
option dns '114.114.114.114'

config interface 'wan'
option proto 'dhcp'
option ifname 'eth0'

修改 /etc/config/wireless 配置文件,开启无线 AP

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
config wifi-device 'radio0'
option type 'mac80211'
option channel '11'
option hwmode '11g'
option path 'platform/soc/3f300000.mmc/mmc_host/mmc1/mmc1:0001/mmc1:0001:1'
option htmode 'HT20'
option disabled '0'

config wifi-iface 'default_radio0'
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'OpenWrt'
option encryption 'psk2'
option key 'passwd.'

让连接路由时,也能ssh上树莓派

1
2
3
4
5
6
7
#open ssh on wan interface

config rule
option src wan
option dest_port 22
option target ACCEPT
option proto tcp

重启树莓派

用一根网线连接树莓派和路由器的 LAN 口,WiFi 连接到 LEDE-WiFi 网络,重新连接 SSH

1
2
ssh root@192.168.1.11
#使用新的IP连接SSH

更新软件包安装LuCI web界面

1
2
opkg update
opkg install luci-ssl

这里安装的是ssl版本

安装软件包

中文

1
2
opkg install luci-i18n-base-zh-cn
opkg install luci-i18n-firewall-zh-cn

打开服务

1
2
/etc/init.d/uhttpd enable
/etc/init.d/uhttpd start

安装ss

http://openwrt-dist.sourceforge.net
直接看上面!

参考链接

http://www.openwrt.pro/post-207.html
http://www.wzero.net/?p=137
http://shumeipai.nxez.com/2015/07/28/install-openwrt-will-be-transformed-into-a-versatile-router-raspberry-pi.html